Topic:   Issue faced while uisng TN migration script
Jun 02, 2014 15:54 2 Replies 790 Views MITHILESH
Prev Next
Topic Replies (2)
  1. 1
    idnkx user

    MITHILESH

    hi,

    We are upgrading to wM9.6 by following side by side update.We have installed new servers for IS and MWS. We are facing issues while migrating the TN components from 8.2 to 9.6 server.

    We tried to migrate the TN components using database component configuration script (./dbConfigurator.sh -a migrate -d oracle -c all -v latest -l "jdbc:wm:oracle://x.x.x.x:1521;serviceName=xx" -u WMLB2IS -p WMLB2IS ) and through database configurator UI by selecting migrate option for Trading Networks.
    while executing the script we were getting the error as migration failed because of " Error in executing file /u01/app/webMethods96/DBconfigurator/common/db/scripts/oracle/isinternal/migrate/40_to_41/ora_isi_m_40_to_41.sql
    SQL error [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-00959: tablespace 'WEBMINDX' does not exist""


    when we tried to recreate the tables for IS and TN after dropping the existing tables using database component configurator drop and create script ,
    it is not allowing us to recreate the internal tables required and is throwing the below error "Error in executing file /u01/app/webMethods96/DBconfigurator/common/db/scripts/oracle/componenttracker/25/create/ora_ctr_c_ddl.sql
    SQL error [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-00959: tablespace 'WEBMDATAT' does not exist
    ORA-06512: at line 13
    ORA-01403: no data found "

    I have tried doing a fresh installation of database configurator and tried running the create script but that didn't made any difference.




    Thanks
    Mithilesh Kumar

    1
    idnkx user

    Pradip

    Mith,

    It seems there are two issues here one is with new tablespace and the other one is with existing

    1) While Creating New Tablespaces, you would see an option in the bottom of DB Configurator Wizard like 'Create tablespace'. Check that option and provide a path. Also you have to provide Oracle's Admin id/pwd (user 'system' and its corresponding password).

    If you have given the SYSTEM (Admin) user credentials, didn't check the option "Create Tablespaces and Database User" though and would have supplied Administrator/manage as the user account where scripts will create all the tables. If you have this user already created and mapped with a tablespace, then you dont have to check this option.. I hope this time you are creating this user only now, and so you have to check this option to have the tablespace associate with it.

    Tablespace Directory can be any physical path in your local system. URL is fine.

    Also try with a local path(C:\webMethods82\SYSTEM) under tablespace directory and check it it works.

    2) For the second issue when you tried to recreate the tables by dropping existing ones you may have messed up with tablespace 'WEBMDATAT

    Thanks,

Leave a Reply
Guest User

Not sure what course is right for you?

Choose the right course for you.
Get the help of our experts and find a course that best suits your needs.


Let`s Connect