Topic:   Unable to start my webMethods Server getting Error can-t retrieve a object within 90 seconds. at com.webmethods.jms.db.impl.JMSConnection.handleException(JMSConnection.java:183) at com.webmethods.jms
Sep 22, 2014 23:50 5 Replies 913 Views Satya Veerendra
Prev Next
Topic Replies (5)
  1. 1
    idnkx user

    Satya Veerendra

    Hi Folks,

    Recently we have done data refresh from one (Ex : QA) Environment to another (Ex : Dev) Environment. After date refresh we are not able to start MWS.
    Logs from errors.log (/opt/webMethods822/MWS/server/default/logs):


    at com.webmethods.jms.db.impl.JMSConnection.handleException(JMSConnection.java:183)
    at com.webmethods.jms.db.impl.JMSPollThread.onRun(JMSPollThread.java:90)
    at com.webmethods.rtl.util.thread.ControllableThread.run(ControllableThread.java:43)
    ]]>









    ORA-27101: shared memory realm does not exist
    SVR4 Error: 2: No such file or directory

    at com.wm.dd.jdbc.oraclebase.ddb9.b(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.ddb9.a(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.ddb8.b(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.ddb8.a(Unknown Source)
    at com.wm.dd.jdbc.oracle.OracleImplConnection.a(Unknown Source)
    at com.wm.dd.jdbc.oracle.OracleImplConnection.x(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.BaseConnection.a(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.BaseConnection.k(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.BaseConnection.a(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.BaseConnection.a(Unknown Source)
    at com.wm.dd.jdbc.oraclebase.BaseDriver.connect(Unknown Source)
    at java.sql.DriverManager.getConnection(DriverManager.java:582)
    at java.sql.DriverManager.getConnection(DriverManager.java:185)
    at com.webmethods.portal.service.sql.core.provider.pool.ConnectionPoolManager.create(ConnectionPoolManager.java:106)
    at com.webmethods.portal.system.pool.impl.LightweightObjectPool.createNewObject(LightweightObjectPool.java:349)
    at com.webmethods.portal.system.pool.impl.LightweightObjectPool.checkOut(LightweightObjectPool.java:277)
    at com.webmethods.portal.service.sql.core.provider.pool.PooledConnectionProvider.getConnection(PooledConnectionProvider.java:181)
    at com.webmethods.portal.service.sql.core.BaseSqlWorker.init(BaseSqlWorker.java:129)
    at com.webmethods.portal.service.sql.DataManager.createWorker(DataManager.java:291)
    at com.webmethods.jms.db.impl.JMSPollThread.onRun(JMSPollThread.java:37)
    at com.webmethods.rtl.util.thread.ControllableThread.run(ControllableThread.java:43)
    ]]>

    1
    idnkx user

    Asadul

    Hi,

    if you could look at the below Error

    CDATA[Error creating database connection to: jdbc:wm:oracle://10.154.1.121:1630;serviceName=WMDB
    CDATA[java.sql.SQLNonTransientConnectionException: [sag-cjdbc42-0011][Oracle JDBC Driver][Oracle]ORA-01034: [b]ORACLE not available[/b]

    seems your database is not available or something might went wrong with your data refresh from DEV to QA. Try to check this with your database team they might help you solving this.

    1
    idnkx user

    Satya Veerendra

    Hi,

    This issue has been resolved now.

    Can you please help me below issue.

    pls tell me about NODE_NAME in cluster.xml and server.properties.bat (or .sh) files .

    By mistake, i've lost node name of one environment. Presently, it showing NODE_NAME is 'default' in both files.

    is it possible to give any NODE_NAME means like 'nrlswmann1.ng.co.us-node*****'?

    i'm asking about node number which will give at end 'node*****'... not about host name 'nrlswmann1.ng.co.us'

    or by chance is it possible to get NODE_NAME with number which i lost?

    Regards,
    Satya

    1
    idnkx user

    Balaji

    Hi Satya,

    I think you were talking about a different issue here now.

    You could use NODE_NAME as any default or alias name of IS and try to maintain the same name across your platform or configurations and properties since this parameter identifies your node uniquely.

    NODE_NAME property usage while running or starting from command prompt

    M:\MWS\bin\mws ‐n node_name start

    To rename a node in a cluster go through 7-1-2_My_webMethods_Server_HA_Documentation_Supplement guide for your reference

    Hope this helps

    1
    idnkx user

    Satya Veerendra

    Thanks for your help.

    I've started MWS by using NODE_NAME as 'default' and it is started.

Leave a Reply
Guest User

Not sure what course is right for you?

Choose the right course for you.
Get the help of our experts and find a course that best suits your needs.


Let`s Connect